Android - No compatible browser found

I am evaluating the okta libraries for my company to see how well it works for OIDC (OpenID Connect). I have implemented the sample program by Mikel Pascual found here:

It seems pretty straight-forward and well-written. But I keep getting this error when attempting to send the user to authenticate via WebAuthClient.signIn(), I get this exception:

2020-10-22 13:04:46.441 28592-28592/com.sleepfuriously.oktatest1 E/MainActivity: null onError
AuthorizationException: {“type”:0,“code”:10,“errorDescription”:“No compatible browser found”}

When debugging, I find that the OktaAuthenticationActivity.getBrowser() method fails to get any resolveIntoList items. Consequently no browsers are found (hence the above error message).

I saw that others have found this same issue:

The above link has a fix, but since this is in library code, I cannot implement those changes. Is there any hope that the libraries will be corrected in the near future? We need to decide on an OIDC solution soon.

smbiggs

Update: This problem was discovered while running an emulator (and yes, I have correctly called setRequireHardwareBackedKeyStore() for emulators–if you do it wrong, a different error message appears). After two days, I still have no solution, even have tried browserMatchAll(true).

Just to be sure, I signed in to google chrome and made sure that my account was active. Still no luck.

But I ran it my personal phone. And it works. That’s nice, but it doesn’t explain the problem–just hacks around it. So when my customers say, “It doesn’t work,” should I reply with, “Try another phone.”?
-smb

@smb The link https://github.com/okta/okta-oidc-android/issues/110 you attached was closed on Nov 7, 2019.
Could you please open a new thread for your current issue on GH https://github.com/okta/okta-oidc-android/issues?