"AuthSdkError" f you cannot use HTTPS, set "cookies.secure" option to false

Can you guide me how to resolve this error, I want to deploy my code on http.

  1. name: “AuthSdkError”
  2. message: “The current page is not being served with the HTTPS protocol.↵For security reasons, we strongly recommend using HTTPS.↵If you cannot use HTTPS, set “cookies.secure” option to false.”
  3. errorCode: “INTERNAL”
  4. errorSummary: “The current page is not being served with the HTTPS protocol.↵For security reasons, we strongly recommend using HTTPS.↵If you cannot use HTTPS, set “cookies.secure” option to false.”
  5. errorLink: “INTERNAL”
  6. errorId: “INTERNAL”

Issue resolved by adding SSL certificate and followed below link:

what if we dont have https server…where should i set cookie.secure to false,it would be very heplful to me

I guess no other options, even I researched lot by setting cookie… OKTA sdk will not allow http. May be you can try to implement test SSL certificate and test.

tokenManager (optional) : An object containing additional properties used to configure the internal token manager. See AuthJS TokenManager for more detailed information.

  • autoRenew (optional) : By default, the library will attempt to renew expired tokens. When an expired token is requested by the library, a renewal request is executed to update the token. If you wish to to disable auto renewal of tokens, set autoRenew to false.
  • secure : If true then only “secure” https cookies will be stored. This option will prevent cookies from being stored on an HTTP connection. This option is only relevant if storage is set to cookie , or if the client browser does not support localStorage or sessionStorage , in which case cookie storage will be used.
  • storage (optional) : Specify the type of storage for tokens. The types are:

under Okta_config

did you tried the above thing?

Yes I did tried secure: true, storage. But no luck. :joy: :joy: