Sign in auth params changing when clicking "sign in with google"

This is what I see in the console when my custom widget is displayed on my login page. Then when I try to sign in with google:

a new window pops up, and when I look at the URL I notice the responseMode has become okta_post_message. When I change this value manually to fragment and try it, I see that I am successfully getting the id_token and state passed to me in the URL.

Am I missing something to get this to work?

Are you looking to have a redirect occur here (when user attempts to login through Google) instead of the pop-up?

Can you try setting authParams.display = 'page' to force a redirection to occur instead, as mentioned in our Widget documentation?

Hi Andrea, yes I am trying to have a redirect instead of the pop-up. I did see that one too and tried that before but I didn’t see a difference. I tried it again and same behavior.


Which version of the widget are you using?

Not sure if this is all that is relevant. I have some okta-idx, okta-react packages and okta-auth as well.


After updating to the latest version 5.9.2, I now get this as my url args…

display page became display popup

Snip from my url:

In terms of what I see, it is the same as before when it was the okta_post_message

What’s the response_mode when the login happens in a pop-up? Are you having issues logging in this way?

I don’t seem to have the response_mode anymore… it got replaced with display page (display param was not passed previously)

The only params I have in the popup url are the following:

It logs in successfully but the redirect is not working back to the window with the widget.

So I’m guessing the authParams I have are the correct ones, but is something missing in my setup still to cause the response mode to change to post message when I was on 5.8.2 and then now in 5.9.2 it goes from display page to display popup?