405 error when trying to a session cookie through the OpenID Connect authorization endpoint

I am trying to get a session cookie as described here:

I can get the seesionToken from this endpoint https://dev-78000243.okta.com/api/v1/authn
with a post body like:

  "username": "xxxxx",
  "password": "xxxxxx",
  "options": {
    "multiOptionalFactorEnroll": false,
    "warnBeforePasswordExpired": false

But when trying to get the session cookie here:


I always get a 405 with this body:

    "errorCode": "E0000022",
    "errorSummary": "The endpoint does not support the provided HTTP method",
    "errorLink": "E0000022",
    "errorId": "oae2DRl0GUmReSIblKbGCCu9Q",
    "errorCauses": []

Hi @ralph.mueller! Perhaps there is a typo in your request - for the error method not allowed https://http.cat/405.

Things to double check:


Thank you, but I checked all that and still get the same 405

Thanks for confirming. Please share how you are making the /authorize call e.g. cURL, Postman, browser? I will try to repro on my end. Are you able to make a regular /authorize request without prompt=none?

Note: You’ll need to be signed in to Okta first before you make a regular /authorize request through the browser for example.

1 Like

Also in this example - Work with Okta session cookies | Okta Developer the redirect uri is encoded. You might wanna try that also.


1 Like

I am using postman, this is now the URL I am using, but I still, get the same error:


I also removed ‘default’ serverid but it does not make any difference. When pasting this URL (without prompt=none) into chrome however the singing page will come up. But my login will not work on that page and I get “unable to sign in”

Do you see any specific errors in the Network events/console when you try to login? Is the same user otherwise able to log into your org with the same credentials by navigating to the main org login page?

Another thing you might want to check is your Authentication/Session policy, in case there is a policy for the specific application in question that is related to this failure.

1 Like

I was able to get it to work in my app. I just cannot get it to work in postman.

Bummer, are you using our Postman Collections by chance -Postman Collections | Okta Developer?