A cookie header was received [...] that contained an invalid cookie. That cookie will be ignored

I’m using the oauth-okta-starter from the okta-spring-boot-login-options-example. When Okta redirects back to my dev server, the handoff fails, presumably because of this cookie parsing failure. I haven’t altered the example in any significant way. Hoping someone can enlighten me as to how to fix this?

2019-09-18 10:39:53.575 INFO 1932 — [nio-8080-exec-1] o.apache.tomcat.util.http.parser.Cookie : A cookie header was received [responseType":[“id_token”,“token”],“state”:“K4VhwJjqTGLVWGYPn3tjqcERHbXob1j6spiyseCtnIafYkgipqlSz1UKEuyAIJzk”,“nonce”:“CojdB7a6LO202rVpB266r9oXW0o5ixSbZDxRXRDZJZs9LX3wpIgZXZ99Dx3pCj7h”,“scopes”:[“openid”,“email”],“urls”:{“issuer”:“https://amway.okta.com/oauth2/aus1h78lyb8aJ7EBp0h8",“authorizeUrl”:“https://amway.okta.com/oauth2/aus1h78lyb8aJ7EBp0h8/v1/authorize”,“userinfoUrl”:"https://amway.okta.com/oauth2/aus1h78lyb8aJ7EBp0h8/v1/userinfo”}}; okta-oauth-nonce=CojdB7a6LO202rVpB266r9oXW0o5ixSbZDxRXRDZJZs9LX3wpIgZXZ99Dx3pCj7h; okta-oauth-state=K4VhwJjqTGLVWGYPn3tjqcERHbXob1j6spiyseCtnIafYkgipqlSz1UKEuyAIJzk; JSESSIONID=C6611CA9DBE08DA54DDDD6849138B215] that contained an invalid cookie. That cookie will be ignored.
Note: further occurrences of this error will be logged at DEBUG level.

I tried the LegacyCookieProcessor and that fails also:

o.a.t.util.http.LegacyCookieProcessor : Cookies: Invalid cookie. Value not a token or quoted value
Note: further occurrences of Cookie errors will be logged at DEBUG level.

If you are not specifically using any cookie value in your code, I think this error can be ignored. oAuth is just token based and this error should not affect the login flow. Do you notice any other issue with the handoff? Anything else in the log?

I believe you are correct that the invalid cookie is not the problem with the authentication issue I’m experiencing. When I tried the same code against an app on the Okta developer portal it works fine. Therefore I would assume the issue I’m having is related to the configuration of my app or our Okta instance.

If you could list the steps you have followed to setup your app, I can assist in validating if you have missed anything.