Authorization server not configured with default connection

Hi all,

I am setting up an OpenID Connect Resource Owner Password flow using the /token endpoint.

At first, I did not configure the password grant type, but once I did that, I now get the following error with HTTP 500 status code from Auth0 (owned by Okta now :slightly_smiling_face:):

  "error": "server_error",
  "error_description": "Authorization server not configured with default connection."

Here is my request:

curl -v -X POST \
-H "Content-type:application/x-www-form-urlencoded" \
-d "client_id=<client-id>&client_secret=<client-secret>&grant_type=password&username=<username>&password=<password>"

I searched throughout the configuration menu but did not find anything which sounds like this. I also tried to use the provided Default Authorization Server to no avail.

Does anyone have a clue?

I found the answer:

  • In Auth0, on the upper left menu, under the tenant name: click on Environment Settings
  • In the General tab, API Authorization Settings: configure the Default Directory value to Username-Password-Authentication

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.