Cannot set PostLogoutRedirectUri

I am using the example located at samples-aspnetcore/samples-aspnetcore-3x/okta-hosted-login at master · okta/samples-aspnetcore · GitHub. I have it configured to allow me to log in, but when when I hit the log out button, I get an error saying that my post logout uri is wrong. I added code to set this, but it seems to be getting ignored. How can I properly set PostLogoutRedirectUri ?

Code I added:
PostLogoutRedirectUri = “https://localhost:44306/signout-callback-oidc

Actual redirect: signout/callback

Desired redirect: signout-callback-oidc

Error message:
“The ‘post_logout_redirect_uri’ parameter must be a Logout redirect URI in the client app settings”

Sounds like you need to add the PostLogoutRedirectUri you configured in OktaMvcOptions as an allowed Logout redirect URI in the Application settings in the Okta admin console (Applications → Application → General → General Settings → Login → Logout redirect URIs), as below:

@andrea , no, I already have that setting on the Okta server. The issue is that this sample application refuses to provide the value that I want as the post_logout_redirect_uri parameter. It keeps setting it to https://localhost:44306/signout/callback, but I need it to be https://localhost:44306/signout-callback-oidc. When I try to set it in code, it doesn’t seem to make any difference.

       .AddOktaMvc(new OktaMvcOptions
       {
            // Replace these values with your Okta configuration
           OktaDomain = Configuration.GetValue<string>("Okta:OktaDomain"),
           AuthorizationServerId = Configuration.GetValue<string>("Okta:AuthorizationServerId"),
           ClientId = Configuration.GetValue<string>("Okta:ClientId"),
           ClientSecret = Configuration.GetValue<string>("Okta:ClientSecret"),
           Scope = new List<string> { "openid", "profile", "email" },

           PostLogoutRedirectUri = "https://localhost:44306/signout-callback-oidc", // "signout-callback-oidc", 

       });