IDX20804 and asp.net core API (Windows 7)


#1

I have an angular front-end (Sign-In-Widget) calling a back-end api server using asp.net core. But what’s happening is when the api server receives the access token from the angular front-end to get access to the API which is running my local machine running in debug mode or my local IIS webserver it doesn’t work. It comes back with an error (Windows 7 Service Pack 1 Enterprise):

System.IO.IOException: IDX20804: Unable to retrieve document from: '[PII is hidden]'. ---> System.Net.Http.HttpRequestException: Response status code does not indicate success: 404 (Not Found).
   at System.Net.Http.HttpResponseMessage.EnsureSuccessStatusCode()

I previously looked online and ran all the items to move to TLS 1.2 in my code as well as the registry setting on my local and it fails to work any other suggestions?

I have this on my Startup.cs:

System.Net.ServicePointManager.SecurityProtocol |= System.Net.SecurityProtocolType.Tls12;
System.Net.ServicePointManager.SecurityProtocol &= ~(System.Net.SecurityProtocolType.Ssl3 | System.Net.SecurityProtocolType.Tls | System.Net.SecurityProtocolType.Tls11);

I’m also including my asp.net core configuration for Okta:

            services.AddAuthentication(options =>
            {
                options.DefaultAuthenticateScheme = OktaDefaults.ApiAuthenticationScheme;
                options.DefaultChallengeScheme = OktaDefaults.ApiAuthenticationScheme;
                options.DefaultSignInScheme = OktaDefaults.ApiAuthenticationScheme;

            }).AddOktaWebApi(new OktaWebApiOptions()
            {
                ClientId = Configuration.GetOktaClientID(),
                OktaDomain = Configuration.GetOktaDomain(),
                Audience = "api://default"

            });

and my registry setting is:

DefaultSecureProtocols is 0x00000800 as outlined in the document below:

https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi