Oktadev/okta-spring-boot-react-crud-example

Hi, I’ve tried to clone this project GitHub - oktadev/okta-spring-boot-react-crud-example: Simple CRUD with React and Spring Boot 2.0

When I run ./mvnw spring-boot:run on spring-tool-suite I got this error

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.0:compile (d
efault-compile) on project jugtours: Fatal error compiling: java.lang.ExceptionInInitializerEr
ror: Unable to make field private com.sun.tools.javac.processing.JavacProcessingEnvironment$Di
scoveredProcessors com.sun.tools.javac.processing.JavacProcessingEnvironment.discoveredProcs a
ccessible: module jdk.compiler does not “opens com.sun.tools.javac.processing” to unnamed modu
le @7a83ccd2 → [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the followin
g articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

I also have this error in the code:

Do you guys know how to fix this issue? I’m using spring-tool-suite.
Thank you.

Can you try installing the Lombok plugin and see if that helps? Eclipse, Spring Tool Suite, (Red Hat) JBoss Developer Studio, MyEclipse

1 Like

Thank for the suggestion, the error in the image above is gone, but the Error: Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.0:compile still showing up:

What version of Java are you using? This example requires Java 8.

My version is 1.8.0_291

This Q & A seems to indicate you might need Java 11. java - Maven Build Failure - Compiler Plugin - Stack Overflow