Social login not appearing in login screen (React sample)

I added Google as an IdP, but it doesnt appear on the login screen. I’m using the React sample.
I use this config:

export default {
oidc: {
clientId: ‘0oaiacjm6kINrzxVr0h7’,
issuer: ‘https://dev-938314.oktapreview.com/oauth2/default’,
redirectUri: ‘http://localhost:8080/implicit/callback’,
scope: ‘openid profile email’,
idps: [
{ type: ‘GOOGLE’, id: ‘0oaiadkyyoJjzGSf10h7’ },
],
idpDisplay: ‘PRIMARY’,
},
resourceServer: {
messagesUrl: ‘http://localhost:8080/api/messages’,
},
};

Shouldn’t this just work now?

Hey @kwaazaar, are you using the Okta hosted login sample, or the custom login sample? If it’s the latter, here is where you need to add idps to the configuration: https://github.com/okta/samples-js-react/blob/master/custom-login/src/Login.jsx#L23-L44

No, I want the login to be hosted as well (minimal impact/lock-in). I expect it to show social login buttons, but it doesn’t. I’m also checking out Auth0, which allows me to specify per application whichs social logins should be enabled. Once enabled they show up automatically, which is what I would expect from Okta as well.