Yarn add @okta/okta-react @okta/okta-auth-js Workspaces error

when using yarn to install okta packages, a double warning (one for each package?) comes out, also a dependency on text-encoding saying it is no longer maintained. how can I resolve these?

% yarn add @okta/okta-react @okta/okta-auth-js
yarn add v1.22.10
[1/4] :mag: Resolving packages…
warning @okta/okta-react > @okta/okta-auth-js > text-encoding@0.7.0: no longer maintained
warning @okta/okta-auth-js > text-encoding@0.7.0: no longer maintained
[2/4] :truck: Fetching packages…
[3/4] :link: Linking dependencies…
warning Workspaces can only be enabled in private projects.
warning Workspaces can only be enabled in private projects.
[4/4] :hammer: Building fresh packages…
success Saved lockfile.
warning Workspaces can only be enabled in private projects.
warning Workspaces can only be enabled in private projects.
success Saved 55 new dependencies…

I discovered that one need no longer install @okta/okta-auth-js anymore as of @okta/octa-react version 5, as @okta/okta-auth-js now a dependency of @okta/okta-react. Now only getting one warning about worksapces.