Absolute callback uri for React app?

In my app settings I have a callback such as http://localhost:3000/implicit/callback

My SPA is using react and the react dom router.
Set up like so: <Route path='/implicit/callback' component={ImplicitCallback} />

But, my confusion here, React router uses hash fragments. e.g. localhost:3000/#/implicit/callback
While the setting in the okta app settings will not allow for # in the uri.

Pressing the login button provided by the examples gives me a 400 bad request page at oktapreview.com, with the following message.
`The ‘redirect_uri’ parameter must be an absolute URI that is whitelisted in the client app settings.``

What am I doing wrong here?

Never mind, I was using the wrong router, using a BrowserRouter fixed this issue

1 Like