AuthApi Error / You do not have permission to access the feature you are requesting

what are we missing here in okta configuration can someone help ?

we are trying to integrate web app with okta and receiving this types of error!


Is this from one of our SDKs? Can you set the Issuer to just your Okta domain? The Widget will try to use the “Default” custom authorization server if you do not configure this, and if you do not have the API Access Management feature, you will not be able to use that server.

Details in the widget docs here.

Hi andrea,

we have just did as you said in the issuer we have set just Okta Domain and tried again the same integration.

Thanks to your suggestion now we are not getting that error any more.

BUT now we are getting stuck at callback means https://OktaDomain/callback - this is the last redirection we are getting.

in the network tab or in the console tab we are not getting any error at all.

what do you suggest ?

Do you see anything being sent to that callback route? Maybe something in the query parameters?

Hey andrea,

We have solved all the error and now okta integration is working end to end.

Thank you so much for your assistance here.

you can close this ticket.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.