Can OKTA SSO run in java 1.6?

java

#1

Hello,

Our clients are on a older version of java and can not upgrade. Has anyone successfully run OKTA SSO on a java 1.6 system? Any help would be appreciated!

Thanks


#2

Okta’s Java SDK and Integrations have a minimum target of Java 1.8. (6 and 7 are no longer supported by Oracle).

That said, Okta uses open standards, you might be able to find an OAuth2 library that supports 1.6 (though I would suggest caution when looking for older libraries)


#3

Great! Thanks for the quick response, we’ll have to figure something out.