Okta-sdk compatibility with jdk 8 and spring 3.2.3

Hi all,
Our application uses jdk 1.8 with spring security 3.2.3. We are planning to integrate with OKTA.
Can anyone please suggest which okta sdk is compatible with above mentioned tech stack or is there any other way to integrate with OKTA?

Thanks

Hi,

Which type of integration do you have

  1. GitHub - okta/okta-spring-boot: Okta Spring Boot Starter
  2. GitHub - okta/okta-jwt-verifier-java: okta-jwt-verifier-java
  3. GitHub - okta/okta-auth-java: okta-auth-java

I will suggest that you can go through the Readme of these integration to get better idea about the versions