Delete Factor doesn't get deleted


trying to do some api tests through postman.
sending a DELETE request to delete a factor… documentation says that the response will be a 204 with no content, but I am getting 200 with content

Also, after doing the delete… I tried to get a list of factors for that user and that “deleted” factor is still there.

Any reason why I’m getting a 200 with content(the factor I was trying to delete) instead of getting a 204 with no content?

Getting really confused here.

This is a problem for me because after sending the delete factor request, I am trying to enroll a new call factor and I’m getting the “A factor of this type is already set up.” error.

Hi perry.rosales

I’m tested the delete factor through postman and it seems to be working. Can you test if you cannot delete only call factors or cannot delete any factors?

Hi abroadhurst,

Thanks for the reply.
As my example above. I am receiving a 200 status with a content in the response when I try to delete factor. This is the case for both sms and call factor. I double-checked by getting the list of factors again after the delete for that User and it is still there.

Documentation says I should get a status of 204 with no content on delete. is this still accurate?

Yes you should get a status of 204.

Do you get the same result when deleting other factors such as Okta push?