IdP Assign to specific groups not working

Hope everyone is doing well and staying safe.

So we’re using the Hub and Spoke method and I’m currently testing and documenting the various steps for both sides. I currently have the Hub set up and have 2 spokes, I set up the 2nd spoke yesterday and as part of my IdP setup, I am doing Group Assignments as Assign to specific groups. I select a group and finish my setup. This 2nd Spoke I set up when I provisioned the first user they went into the Everyone group and I had to manually assign them to the correct group. From the Hub were no errors in the logs, and on the Spoke there were no error in the logs.

My questions are:

  • Is there a process or step I am missing?
  • Is this a timing issue where maybe I provisioned before some other step?
  • Is this because he was a member of a group that exists already in the Spoke that exists in the Hub that they got assigned there instead, even though you can be assigned to multiple groups?
  • Something simple I am not thinking of?

So in case anyone else is looking for options here is what happened some of which ended up happening because of timing and some testing issues on my side.

The over arching reason for the user not getting assigned was because I hadn’t tried to login with the user I had only provisioned them. Once I tried logging in they got assigned and everything worked out. I still think its a little odd that they wont get assigned on provisioning but it does work as intended. The other issues the user had was during testing I had him assigned to a different group and they had already logged in a few times, so my assumption was they would be updated when provisioned and that wasn’t the case.