Issue with Angular Module Federation and okta-auth-js

I’m seeing the following error when I try to run an app using module federation

@okta/okta-auth-js/esm/browser/index.js
No version specified and unable to automatically determine one. No version in description file (usually package.json). Add version to description file

I’m not entirely sure how to deal with this as I can’t update the package.json file of that library. Any suggestions?

Hey there! What versions of Angular & okta-auth-js are you using? Also, are you using nx or @angular-architects/module-federation to scaffold/configure the module federation?

You might also want to check out the webpack config file in this blog post & associated GH repo that incorporates okta-auth-js in an Angular v13 MFE project using @angular-architects/module-federation.

Final project GH repo - GitHub - oktadev/okta-angular-microfrontend-example at deploy

Keep us posted!

I’m using Angular 14 inside of an Nx 14 workspace. I used Nx to scaffold the micro frontend.

I just tried upgrading the sample repo I posted to Angular 14 and the latest versions of @okta/okta-angular and @okta/okta-auth-js, and I see the same error. This error appears specific to the latest version of @okta/okta-auth-js and module federation? I will file an issue with the SDK team.

Using @okta/okta-angular@5.2.0 and @okta/okta-auth-js@6.4.3 works for me. Can you try these versions of the Okta SDKs in your app? Let us know if this resolves the problem for you!