Logout Issues in Okta

Hi,

When I logout from my application, the paratamter which is generated is as below :-
https://dev-24929638.okta.com/oauth2/default/v1/logout?id_token_hint=*****&post_logout_redirect_uri=http://localhost:8080/graphdb-web/

But this is not where I want to redirect my application. I want to redirect to the Okta main login page.

I defined logout uri as http://localhost:8080/graphdb-web/ then application redirects to the my landing page which is not required.
If I change my logout uri in okta app I get 404, as my brower shows post_logout_redirect_uri=http://localhost:8080/graphdb-web/

Please suggest

I want to understand how my URL in the browser is generating
post_logout_redirect_uri
even if it is not there in the application(Okta)

@mraible can you suggest?

What type of application is this? Are you using one of your SDKs? It sounds like your application needs to be configured to use the desired post_logout_redirect_uri, but we’ll need more information to tell you how to do so.

I followed the steps mentioned in Add User Authentication to Your Angular App | Okta Developer

After successful logout , idealy the url which is generated in the broweser should have
the logout uri which is mentioned in the application.
but the paratmeter “post_logout_redirect_uri” is taking windows origin I supoose.
Why is such behaviour happening?

Signing out of Okta requires the app to open a browser and navigate to the end session endpoint. Okta ends the user’s session and immediately redirects the user back to your application. To do this, you must define a callback route for the sign-out process, which means that you need to allow the post sign-out URL in your Okta app integration settings. If you don’t specify a post_logout_redirect_uri , then the browser is redirected to the Okta sign-in page.

I dont want to redirect to my application , I want to redirect to Okta sign in page.

But as mentioned in the doc. If I dont assign the logout uri in my Okta App. it shoudld redirect to my okta sign in page. but instead it gives me 400. stating

Your request resulted in an error. The ‘post_logout_redirect_uri’ parameter must be a Logout redirect URI in the client app settings.

Currently the url(after logout) in my application , the pararmeter “post_logout_redirect_uri” is being picked up as windows.origin.

logout?id_token_hint=eyJraWQiOiJya2o2ZWpIYzVxY0JsM…ri=http%3A%2F%2Flocalhost%3A8080%2Fgraphdb-web%2F

I tried to set
await this.oktaAuth.signOut(“http://localhost:8080/graphdb-web/login”);

Got an error :- Cannot create property ‘postLogoutRedirectUri’ on string ‘http://localhost:8080/graphdb-web/login