MFA Enroll Screen

Hi,

Screenshot 2021-08-17 14:02:26
In the above-attached screenshot, how do we change the text “signing into Okta account” to something more meaningful and custom message like “signing into XYZ account”, as it might mislead when the customer is challenged for MFA for different applications.

Given that we use Okta-react SDK and also have Custom URL Domain Configured.

Thanks and Regards
`

The text you are seeing should only appear when you use the Okta hosted default login page (*.okta.com). When using your Custom URL domain instead (make sure the application/authorization server you are using is correctly configured to use the custom domain!) it should simply say “signing in to your account”
Screen Shot 2021-08-17 at 11.18.11 AM

See widget source for reference: okta-signin-widget/login.properties at master · okta/okta-signin-widget · GitHub

If you want your custom login page (Okta hosted or otherwise) to say “signing in to your XYZ account” you can set the brandName in your widget config to “XYZ” which will also brand similar widget text accordingly.


Screen Shot 2021-08-17 at 11.20.53 AM

Hi…I have checked and can confirm that the authorization server is correctly configured to the custom URL domain. Can you pls specify how do we configure the brand name in Okta React SDK?

If you are using a self-hosted widget, you will add the brandName to your widget config, e.g.

var signIn = new OktaSignIn({
    baseUrl = OKTADOMAIN,
    brandName = "XYZ"
})

If you are redirecting to Okta to use the Okta hosted Custom Sign In Page, you will need to modify the page (as I’ve done in my screenshot above) in the Admin Console: Settings → Customization → Custom Sign In. More details about the customizations available here: Style the Okta-hosted Sign-In Widget | Okta Developer