New user is not assigned to group 'Everyone'

Hello,

Since a few days new users are not assigned to the group ‘Everyone’ by default.
How can I achieve that again?

Thanks in advance,
Daniel

In addition: The problem is that now no applications are assigned to a new user. Now I always have to assign my apps to a new user… Is there a way how I can do that now? Previously that worked.

Every user is added to Everyone group by default - there is no exception. How are you creating the users? Maybe that process has some quirks?

It is possible to create another group named ‘Everyone’. Was this done by any chance or pulled in from another source like AD or LDAP?

My fault, right! Users are assigned automatically to “Everyone” but my problem right now is that no default application is assigned to the user.
@erik How can I achieve that again?
Thanks!

No I have two ways how I add new users: Just via the UI (Firstname, Lastname, Email) or via the API (Firstname, Lastname, Email).
Previously the applications were automatically added to the new user - Now new users have no application per default.

So, users are getting added to everyone group but don’t have apps assigned? You can check that all the apps have the everyone group assigned to them. Also check if you have any group rules that might be bypassing the assignment.

Correct.
In “Applications” - Select App - “Assignments” the Group ‘Everyone (All users in your organization)’ is assigned.
Also for my other 2 apps - Assignments - “Everyone”. (I see all my Apps in the “Groups” section)

I cannot see group rules… I have the feeling that this is new since the redesign/new UI.
Is there anything else I can check?

Can you check the system logs for a newly created user and see whether user got added to all the assigned apps? If there was an error, you should be able to see it there.

Also, if you have provisioning on the app, you can check for provisioning errors on the tasks page.

1 Like


Doesn’t seem like an error right?

Could you get log specific only to the newly created user? Find the user in directory and click on logs from there. You should be seeing app assignment logs after the create user. That’s where we can see if there is an issue with app assignment.

I see no (relevant) additional information when I expand the information here…
There is no assignment - Should it be there?

,

Strange to me is also when I open details of a user (see image) there are no application (ok, that’s the problem) but when I click on “Assign Applications” than I acpect, that I can choose my applications.
But this list is empty?!

How I workedaround it until now:
Via “Applications” I see my avaialble apps. I select each of them and via “Assignments” I assign the user to this app.

Maybe one think: Via the “Profile Editor” I added a new attribute (Attribute Type Custom) but a month ago that worked too so…

Yes, as soon as user is created, each app assigned to the everyone group gets an entry here. Something is fishy. Are you able to see the everyone group under the groups tab for the user or search for the user under the everyone group? As Erik pointed out, do you have multiple everyone groups?

Yes, I see ‘Everyone’ in the groups tab (With correct number of people + correct number of apps)

I have one other group but I have not assigned people there (could delete it)

If the other group has a different name, it shouldn’t matter. If it’s the same name and was created via some integration, that could be the issue, although, I don’t know how to fix that. Will let Erik answer in that case :slight_smile:

One last thing I can think of, what’s the user status of the newly created user? Is it staged, provisioned or active?

Ok thank you!

Status after creating a new user: Pending user action.
After this action (user gets an email to activate the account) the status is active but still there are no apps.
Hm wait, can it be that there is an option where the user has to choos the apps?

Check the user logs after user status becomes active (with a test user). The app assignments should be there at that time as well as errors, if any.

And sorry for asking a basic question: how do you say user has no apps? Because nothing comes up on the Okta dashboard after login for the user or because the apps are not shown as assigned on the user profile in admin console? If it’s the former, check the app config under general tab to see if app has been hidden from the dashboard.

Confirm if user is really unable to access the app - Use an idp initiated login with a new user and test.

Fixed it:
In the Profile Editor i updated the “Mappings” with my new created attribute.
Now the applications are assigned correctly to the user. Let’s see if everything works fine.

@gsvivek Thank you so much for your help. Have a nice weekend!