Okta SAML Post response not sent if the user has to login to their Okta account

Hello all,

I am having a issue with the Okta SAML Post response not being sent after the Okta user logs into their account but the Okta SAML Post response is sent if the Okta user is already logged in.

This works (user already logged into their Okta account):

  • service sends the user to login via the Provider Single Sign-On URL
  • the user is already logged into their Okta account
  • the SAML Post response is sent from Okta
  • service validates the response and logs the user into the service

This does not work (user is not logged into their Okta account):

  • service sends the user to login via the Provider Single Sign-On URL
  • the user logs into their Okta account, using Google account to login
  • the SAML Post response is never sent from Okta

I am using an developer account for the Okta SAML integration and have assigned the dev account as a user to the service App.

Is there a config setting somewhere that can revolve this issue?

Alex

@AlexDarby
For this SAML issue, can you please open a support ticket through an email to support@okta.com? One of our TSEs will take a look of your questions.
Thanks

Hello,

Found out this is due to using the developer account admin as a App user and also using Google to login into the developer account / App user account.

Added a new user to the App and everything works as expected. User can sign-in and response is sent back or user is already signed-in and response is sent back.

Adding this reply in-case anybody has this issue in the future.