Sign in oddness at

I’d initially come here using Chrome. In trying to log in with Firefox, it was going right to the screen suggesting [company] Filling in the domain in my email for “company” didn’t get anywhere successful. On going back to Chrome I see that what goes there is for some reason “dev-08889nnn” (partly obscured with “nnn” here – is that secure to share in full?). When I put that into the “company” blank in the sign in form in Firefox, I got a 401 error. However if I just put in the URL bar: I was finally able to get Firefox to sign in.

So there’s that. Also, it would be convenient if, as suggested by the form, the location truly were “” rather than dev-… I can’t see any option to make it so. Is there one?