Unable to open Okta Login page from Application getting 404

Hi All,

I am unable to login to Okta with my domain account username for my application ; since my application is using the authorize url with the dev domain account it is also getting a 404; I have tried to hit the default url separately and its giving me same 404 error.
Is there any way I can verify that the login page is working with default url
https://dev-42202531.okta.com/oauth2/default before I access from my app ?
What could be wrong with the configuration?
I have verified clientId and domain with redirect_uri and they look good.

Thanks and Regards,

Can you clarify how you’re encountering this issue? Are you constructing an /authorize request, such as https://dev-42202531.okta.com/oauth2/default/v1/authorize?client_id=xxxx&redirect_uri=yyyyy....

Hello Andrea thank you for responding to my query ; you are right I am encountering the issue while accessing the authroize from my spring boot app where I am passing domain, client_id and redirect_uri as per documentation ; the grenerated url has a lot more other requestparams apart from the mentioned three though.(eg. scope,state etc)
Additionally I can only log into Okta using my google account ; however the users I have setup cannot login using the password configured and I am not getting any options to reset password for those users; it has been disabled.
Please let me know if you have any other suggestions.

Its hard to guess what the issue is based on this information.

Is the 404 getting returned by an Okta endpoint, or from within your application (for example, at the redirect_uri you’ve specified).

As for the other users that are local Okta users that cannot login, have they ever been able to login, or is the issue mostly that they are unable to reset their passwords? If the latter, what happens if they try?

Hi Andrea,
It was failing and getting 400 while hitting the authrorize url…I can load the okta page now. The issue was with the redirect_uri ; I had the whole url .However I am still not able to login with the dummy users as I am unable to reset their password…when I select forgot password it gives me following

Do you have any suggestions how I can enable the users to reset their pass?

Hmm… are the policies in your org configured to allow for Self-Service Password Recovery (Okta Classic guide/Okta Identity Engine guide)?