400 Bad Request - Description: The 'redirect_uri' parameter must be an absolute URI that is whitelisted in the client app settings


#1

I followed the instructions given in sample-nodejs-express-4 and also went through following bug Error 400 bad request. I am still getting the issue reported in the bug.

I have put the login-redirect-url as localhost:8080/ itself and added localhost:8080 in the trusted origins.

Thanks,
Prasad


The 'redirect_uri' parameter must be an absolute URI that is whitelisted in the client app settings
#2

Adding redirectUri in .sample.config.json matching with application in okta solved the issue. You can close this ticket.


#3

“Adding redirectUri in .sample.config.json matching with application in okta solved the issue”

Can you explain this more in detail? What setting? Where?


#4

@mike_montana did you come right in finding out what you need to fix the 400 error?


#5

Hi @G71

Please check the article available here on the redirect_uri issue.