Callback url not handeled by LoginCallback Component

I am integrating the Okta Auth in a React Single Page Web App and I when I login I am redirected to my Callback URL with a state and code parameter but no # as described in the manual.
The callback URL does not seem to be handeled by the given LoginCallback Component.
What am I doing wrong?

Can you check out our React sample app and see if it works for you: https://github.com/okta/samples-js-react

Hi andrea,

I tried but it is annoying because the example does not work. When I exactly follow the instructions I get a message concerning a babel-jest dependency…

tried all workarounds (1 to 7) but nothing helps. can you help?

There might be a problem with the project dependency tree.
It is likely not a bug in Create React App, but something you need to fix locally.

The react-scripts package provided by Create React App requires a dependency:

“babel-jest”: “^26.6.0”

Don’t try to install it manually: your package manager does it automatically.
However, a different version of babel-jest was detected higher up in the tree:

E:\Intelliact\www\samples-js-react\okta-hosted-login\node_modules\babel-jest (version: 27.5.1)

Manually installing incompatible versions is known to cause hard-to-debug issues.

If you would prefer to ignore this check, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That will permanently disable this message but you might encounter other issues.

To fix the dependency tree, try following the steps below in the exact order:

  1. Delete package-lock.json (not package.json!) and/or yarn.lock in your project folder.
  2. Delete node_modules in your project folder.
  3. Remove “babel-jest” from dependencies and/or devDependencies in the package.json file in your project folder.
  4. Run npm install or yarn, depending on the package manager you use.

In most cases, this should be enough to fix the problem.
If this has not helped, there are a few other things you can try:

  1. If you used npm, install yarn (http://yarnpkg.com/) and repeat the above steps with it instead.
    This may help because npm has known issues with package hoisting which may get resolved in future versions.

  2. Check if E:\Intelliact\www\samples-js-react\okta-hosted-login\node_modules\babel-jest is outside your project directory.
    For example, you might have accidentally installed something in your home folder.

  3. Try running npm ls babel-jest in your project folder.
    This will tell you which other package (apart from the expected react-scripts) installed babel-jest.

If nothing else helps, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That would permanently disable this preflight check in case you want to proceed anyway.

P.S. We know this message is long but please read the steps above :slight_smile: We hope you find them helpful!

I was able to fix this issue - was a eslint problem with linebreaks

1 Like

OK, the sample is up and running and works - the integration in my own app still does not work

callback does not seem to be handeled - after login the app stays at the following url:
http://localhost:3000/login/callback?code=h3P_pHCoL9GeKsZnoUi09sl0PyNlvbSSe8VTqomx4sM&state=w8B9du6XqJbLP6juqJQFzVbFTxCC7Srh6Mi60Vd4WgFQl1xdSVE0qWeIyZ4b3grR