Description: The 'redirect_uri' parameter must be an absolute URI that is whitelisted in the client app settings

I think I have this configured correctly. It runs fine on localhost but when I upload it to the server it crashes with the above error. These are some of the settings. It is in Angular 8 and I am using a Chrome Browser. Based on the Angular Calculator Authentication example: https://developer.okta.com/blog/2019/02/12/secure-angular-login

When I publish the application, I get a 400 error. Description: The ‘redirect_uri’ parameter must be an absolute URI that is whitelisted in the client app settings.

const routes: Routes = [
{ path: ‘implicit/callback’, component: OktaCallbackComponent},
{ path: ‘login’, component: LoginComponent },
{ path: ‘calculator’, component: CalculatorComponent, canActivate: [OktaAuthGuard], data: { onAuthRequired } },
{ path: ‘’, component: HomeComponent },
{ path: ‘calculator’, component: CalculatorComponent },
];

@NgModule({
imports: [RouterModule.forRoot(routes,{enableTracing: true})],
exports: [RouterModule]
})


OktaAuthModule.initAuth({
  issuer: 'https://dev-902851.okta.com/oauth2/default',
  redirectUri: 'http://callsoftwaresupport.com/implicit/callback',
  clientId: '0oa1bf36jzFO5fC3j357'
}),  

You’re missing the .com in your Okta settings.

Thank you for your code review, sir. I added the .com and it worked.