Error trying to load sign in widget from CDN

I’m trying to do nothing more than load a Web page with the script tag for the okta sigin in widget:

<script src="" type="text/javascript"></script>

I have the script tag in the head section of my web page.

In the Chrome console I get a JavaScript error indicating “Uncaught SyntaxError: Invalid regular expression.” This error is followed by half a page of control characters. Then at the bottom the error indcates: Range out of order in character class in new RegExp(anonymous) at jsonpath.js:206.

I’ve tried this in Chrome, Firefox, Edge and even Internet Explorer and I get the same error in every browser. I tried re-typing the script tag manually in case I accidentally included some control characters when copying and pasting from the sign in widget guide. Same error.

I can copy the link out of the script tag, paste it in a new browser window, and it downloads the js file without error.

Hopefully someone has an idea about this. I can’t even get started.

Are you still running into this issue? I just changed one of my Widget forms to use 5.1.5 and it loaded the widget from the CDN fine. If it is working for you now it could have been an issue that was fixed since.

If you still receive the same error, but are able to download the script in your browser, what happens if you change your web page to load the widget script from the locally downloaded copy?

Well, the odd thing is that after I started everything back up this morning the file was able to load fine from the CDN without errors. Obviously it was something local to my environment and not a problem with the file or the CDN. I should have rebooted first before posting the issue. My apologies for that.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.