Generic OpenID Connect Identity Provider is not possible

Hi,

Currently i have 2 accounts, one “developer” and another “trial”, and according to this docs https://developer.okta.com/authentication-guide/generic-oidc/#configure-the-idp-in-okta is possible to add my own OpenID Connect Identity Provider.

Here the steps from the docs:

"To connect your org to the IdP, add the IdP that you just created.

  1. In your Okta org, select ‘Social & Identity Providers’ from the ‘Users’ menu.
  2. Click ‘Add Identity Provider’ and select ‘Add OpenID Connect IdP’.

    "

But the option “Add OpenID Connect IdP” is not displayed, just Google, Facebook and SAML 2.0.

Is this has anything to do with being a trial or developer account?

Att,.

Hi @Juroviol

The feature in question is GENERIC_OIDC_IDP which became GA in preview along with the last major release. If your developer tenant is under *.oktapreview.com, you can request it through a support case from Okta Support Portal or by email at support@okta.com.

For production environments (*.okta.com or *.okta-emea.com), the feature can not be activated yet as it is in beta status.

Hello @dragos

Thanks for clarification.

Yes via feature flag:

image

@Govner

I don’t undestand. Is something i’ve to do in my account?

Att,.

@Govner anyway, as @dragos said, this feature is not production ready.

All Early Access features receive the same SLA support as GA

I went to Settings->Features and didn’t see anything there that related to OpenID Connect IdP.

So I enabled all early features just to see. This didn’t show up.

Is there somewhere else I need to go to set this feature flag?

Hi @ksonderegger

Please send an email to support@okta.com and request for the feature GENERIC_OIDC_IDP to be enabled on your Okta org.