Login infinite loop after MFA configuration

After trying to disable MFA for my developer account (which uses Google to login), I’m stuck in an infinite loop.

Here are the steps:

  1. Go to the login page for developer accounts
  2. Click on “Continue with Google”
  3. Let the infinite cycle begin!

Looking at the network requests, I can see that the looping starts after a request to Google is made (so I’d believe I effectively logged into Okta), and Okta gets to a “Set up multifactor authentication” but since I configured my account to not require MFA, I’m being redirected to another page(s) which in turn send me back to the “Set up multifactor authentication” page and again to…

Screenshot 2024-06-14 at 9.14.22 AM

I’m guessing some code really wants me to set up MFA, while the other one accepts the fact that I have disabled MFA.

Any advice into how to get back into my developer account?

1 Like

Try clearing your browser cache and cookies, then log in again

Same for me, but with user-password login. Clearing cache and cookies doesn’t help. Same issue on different machines and different browsers.

Hi,

Can you try adding /login/default to your okta domain and see if you are able to access your account. Something like this https://{your_okta_domain}/login/default.

If this doesn’t works, we recommend reposting your query on Okta’s Community at: Okta Help Center (Lightning). Okta’s teams on the Community are better equipped to provide the comprehensive support and guidance you need as they have the specialised knowledge and expertise in this situation.

Thank you for the suggestion, unfortunately it doesn’t resolve the situation. My problem is not necessarily with login (I do see the request to Google and sent back to Okta), but with enabling 2FA after authentication.

I initially tried asking in Community as you also indicate, but I can’t get past a page that shows “Error - Your account has not been configured for the link/application you are trying to access. Please contact Okta Support and request that your account be configured for the link.”

Any other suggestions will be greatly appreciated!

@metalmario experiencing the same issue on my end as well. anyone able to figure out a workaround for this as of yet?

I am facing same issue. How to proceed?

Shockingly I am having the same issue. Had some new notification today that I needed to enable MFA per my “admin” policy. I then disabled it and can’t log in. So I cannot re-enable MFA, and I cannot log in to submit a case. Pretty much SOL. Don’t believe I received any notification about this change to require MFA for admins either.

There is currently an issue with creating new accounts via social idP. We do have an internal query on this and it’s being investigated. The cause is due to the auto-enabling of the feature that requires MFA for access to the Admin Dash, and with social idP you aren’t prompted to set up a second factor. This only happens with social idP at this time.

@metalmario @Venellede @hommer @neenu1 @nedemuth

please DM me with your dev org domain and the email address you used to sign up with, and I will go in and disable the setting so you are able to acess your orgs!

cc @vk-giri

3 Likes

I am not able to send a message to you with details.
Getting pop up - 'An error occurred: Sorry, you cannot send a personal message to that user. '@nicole

1 Like

I am also running into the issue with an infinite redirect loop in the admin console after disabling the MFA (which was auto-enabled) on an Okta admin account signing in through Google. I am not able to DM you as far as I can tell but I really need this resolved as I no longer can access the admin console.

Thanks for the help offer! Would you be able to indicate how we can send you a DM, or provide you our dev org domains?

Thanks again!

Hi @nicole I also need help with this but cannot DM. Can you reach out, thanks!