Not found: Resource not found: (CustomDomainCertificate)

I am getting the following error:

Not found: Resource not found: (CustomDomainCertificate)

when customizing the domain url in the Okta settings.

I followed the instructions in order to generate the proper certificate Gather information | Okta Developer

does anyone have ever seen this?

@fafe77 Which step of the domain set-up is resulting in that error?

Hi @andrea, in the certification step:

Seems odd. Does the same issue persist if you log out and log back in or if you try a different browser?

I tried again after logout and log back in but it’s still the same. Same goes in another browser.

I noticed I enter the -----BEGIN PRIVATE KEY----- inthe private key text area while in the info tooltip I am asked to enter the -----BEGIN RSA PRIVATE KEY-----

I don’t have any -----BEGIN RSA PRIVATE KEY-----

These are the files from my provider of the cert:

This file is README.txt
Your certificate file is mydomain_2021-06-15.crt
Your intermediate certificate file is ca_bundle.crt
Your certificate private key file is mydomain_2021-06-15.key
Your certificate private key file is mydomain_2021-06-15.protected.key (password protected key, incompatible with some hosters)
Your private key passphrase is in passphrase.txt
Your certificate file for Windows is mydomain_2021-06-15_windows.pfx (Import password is in passphrase.txt )

What CA are you using?

I’m using Let’s Encrypt to get a cert for my org and my key looks the same as yours but I’m not experiencing this issue. Provided these are PEMs and you are providing the complete key/cert when prompted, with no trailing/leading whitespace, I don’t see what the problem could be.

To get further assistance on this, you may want to open a support case so a member of our Support team can check our logs to see what is causing this issue.

I am using a Sectigo signed DV certificate.

But if you are using Let’s Encrypt does that not mean you need to update the cert on a 3 month basis?

I’ll open a support case btw, thank for your help so far.

I do :frowning:, so might not be the best idea to do this unless you’re just testing something like I was.