Okta Angular SDK installation warnings


#1

Hi

When I try to install okta angular sdk below are the warnings I get. Is there anything I need to do in addition to just the install command.

 npm install @okta/okta-angular --save
npm WARN @okta/okta-angular@0.0.13 requires a peer of @angular/common@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @okta/okta-angular@0.0.13 requires a peer of @angular/core@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @okta/okta-angular@0.0.13 requires a peer of @angular/platform-browser@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @okta/okta-angular@0.0.13 requires a peer of @angular/router@^4.0.0 but none is installed. You must install peer dependencies yourself.

Below is the Angular CLI and Angular versions my project is on.

Angular CLI: 1.6.3
Node: 9.3.0
OS: darwin x64
Angular: 5.1.1
... animations, common, compiler, compiler-cli, core, forms
... http, language-service, platform-browser
... platform-browser-dynamic, router

@angular/cli: 1.6.3
@angular-devkit/build-optimizer: 0.0.36
@angular-devkit/core: 0.0.22
@angular-devkit/schematics: 0.0.42
@ngtools/json-schema: 1.1.0
@ngtools/webpack: 1.9.3
@schematics/angular: 0.1.11
@schematics/schematics: 0.0.11
typescript: 2.4.2
webpack: 3.10.0

#2

These are warnings because we want our SDK to work with Angular 4.x. We could probably increase the version range so 5.x is included. Everything should work fine with Angular 5.1.x. Please let us know if it does not and we’ll get it fixed.


#3

I a facing same issue "Okta Angular SDK installation warnings "
Please update this library - “@okta/okta-angular”.


#4

I am facing the same issue - Okta Angular SDK installation warnings
Please update your library - @okta/okta-angular.
Thanks in advance.


#5

Hi,
I have the same problem. Did you find a solution, please?


#6

These are just warnings. Okta’s Angular SDK 1.0.0 works just fine with Angular 5.x.