Popping open the login widget

I have an application set up. It is at dev-92265269.okta.com. When I paste that into my incognito browser, it opens the sign-in widget fine. But when I try to get to it via my wordpress landing page, my Dashboard opens instead. Here is what the link in wordpress/elementor looks like:
window.open(“http://dev-92265269.okta.com”, “_blank”);

Can anyone tell me how to get the widget to open instead of the Dashboard?

Are you already logged in to Okta when you test on wordpress? Does the same thing happen if you test in a private browsing window/clear your cookies & cache?

Exactly, I started testing from Incognito and it went away. Thx!

If there’s already an Okta session (the session cookie ‘sid’ on the Okta domain) in the browser, then opening the login page will immediately result in a redirect to the end-user dashboard. There’s no way to prevent this from occurring as the login page will automatically check for the existence of this session.

OK. Not a good look! Thx. Are you with Okta? If so I have another question. I have set up my app. I am trying to use the okta login widget, just with my logo instead of okta’s. I can get the widget to pop now, but 1) my logo is missing 2) when the user adds themselves to register and the confirm email gets sent, the user clicks on it and again the dashboard opens. Is this the same issue?How do I deal with this?

Thx for your help.

You’ve got the widget loaded in your app instead of redirecting to Okta? You have two options depending on what you’re doing.

  1. If you are hosting the widget yourself, you can specify the path to a logo (local or URL) to display in the widget as part of the widget config. More details in the widget documentation: GitHub - okta/okta-signin-widget: Okta SignIn widget that renders the new login/auth/recovery flows
  2. If you are redirecting to Okta, you can configure a logo for your org within the Okta Admin Console under Settings → Appearance → Organization Logo.

And yes, if the user follows the link in the email to confirm their account, they are immediately logged in and will be sent to the end user dashboard.

If you want different behavior, take a look at the “Default App for Sign-In Widget” feature, which allows you to automatically redirect all users to the URL of your choosing when they attempt to access this dashboard. If you don’t see the settings for “Default App for Sign-In Widget” under Settings → Customization → General, you may need to enable this feature, which is labelled as “Global Default Redirect Setting” under Settings → Features → Early access

Thanks Andrea. I am trying to do number 2 in your choices, but I only see Accounts, Features, and Downloads under settings in the Dashboard. Is there another place I should look for Appearance?

On setting the Default App, I don’t see Customization under settings. I do see Customization from the main choices, but not General.

I then tried to enable it in Early access but I don’t see “Global Default Redirect Setting” as one of the choices. see image

Can you open a support case so that you can get the necessary feature enabled in your org and help with any other lingering issues you’re having setting up the logo?

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.