SPA redirect sign in not storing token in local storage

The redirect sign in works for me on Firefox but does not work for me on Chrome. It also does not work for one of my team members on Firefox.
Chrome versions tried (all Windows x64): 108.0.5359.100, 108.0.5359.125
Firefox versions tried: 107.0.1

I logged the token output and see that isAuthenticated is true and that there is an access token and an ID token being received. I also see the cookies are properly created, but in Chrome I do not see any Okta data in local storage while in Firefox I do see Okta storing token data. My peer using Firefox also strangely did not have any data stored. Even if I log out of Okta and clear my local storage everything still works on my Firefox…

I followed the SPA redirect guide for React here: Sign users in to your SPA using the redirect model | Okta Developer

This is the error:
AuthSdkError: getUserInfo requires an access token object

I have tried clearing the Chrome cache, cookies, etc and still have had no luck.

These are the dependencies in the project:

  "dependencies": {
    "@okta/okta-auth-js": "^6.9.0",
    "@okta/okta-react": "^6.6.0",
    "@testing-library/jest-dom": "^5.16.4",
    "@testing-library/react": "^13.3.0",
    "@testing-library/user-event": "^13.5.0",
    "axios": "^0.27.2",
    "react": "^18.1.0",
    "react-dom": "^18.1.0",
    "react-router-dom": "^5.3.3",
    "react-scripts": "^5.0.1",
    "react-timer-hook": "^3.0.5",
    "web-vitals": "^2.1.4"

Ah, I really don’t know what happened or how it was working on one of my browsers, but I think something funky happened with our deploy system. I can’t tell exactly what it was doing but it was messing up something when building which caused login to fail. Fixed that and now I can sign in on chrome and so can my colleague

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.