State error. Make sure cookies are enabled

We are trying to integrate OKTA widget on a Wordpress site. We are receiving this error after they authenticate with OKTA login screen on Wordpress

“State error. Make sure cookies are enabled.”

Any help would be appreciated.

Same issue here. Could you figure out why this happens. We had a few users reporting this issue, while other had no issues login-to WordPress with the Okta plugin

It looks like the widget is checking for a session state against the get parameter in link 138 on the okt-widget.php file

_GET['state'] != _SESSION[‘okta_state’]

It might be that the session was not set.

This is likely because either cookies are disabled on the domain, the URL you’re starting at is different from the redirect URL (http vs https, localhost vs 127.0.0.1, etc), or something went wrong starting the session.

However, there is a new version of the plugin out which works differently and this error message is no longer part of the code. If you update to the latest code from github it should work now.