The 'redirect_uri' parameter must be a Login redirect URI in the client app settings

I recommend reviewing the documentation for the .NET Core library if you haven’t already. You can add these missing properties so that you can set a value different from the default, including the CallbackPath (which dictates the redirect_uri) and the PostLogoutRedirectUri: okta-aspnet/ at 4c6d815a6b73ad563e847fad541d7b33fdb8762c · okta/okta-aspnet · GitHub

Thank you very much for the help. However, I had read this and tried this before I post here for help. It does not work. The issue is underlying the .Net Core library From the url it composed, you can see redirect_uri is always as authorization-code/callback, no matter what you set in AuthenticationProperties. When signing out, it is the same. The redirect uri is always something like …/callback…

I am trying to use OktaMvcOptions to feed the callbacks. But got the follow errors. Any idea?

What did you set as your PostLogoutRedirectUri? It looks like the SDK/OWIN is expecting a relative path for whichever option is causing that error.

Thank you very much for looking into this. Your tip works partially. Below is what I had. After I changed to relative, it works and I can sign in. But Sign Out still not working.

  1. What I had
  2. What I have now
  3. Sign out still not working. The composed URL is not what I set

Can I conclude that PostLogoutRedirectUri in .Net Core is not customizable??? Thanks.