Unable to access applications on SSO using SAML

Hi Everyone,

I’m trying to connect to Google Workspace via Okta IDP using SAML 2.0 for our company (to all users). I’ve tried using 1-click configuration to configure Google Workspace directly and added missing URLs.
Background:

  1. Using Testing tool - Connection is shown Allowed.
  2. Enabled Provisioning and Authenticated API integrations
  3. Imported users from the company domain to the app and assigned them to the app.
  4. On Google Admin-console >> Security >> Authentication >> SSO using third-party IDP >> Manage SSO profiles and set up the new Okta-generated SSO profile for Google workspace as the SSO profile for the entire organization.
  5. Checked Okta system logs - All events success
  6. Checked OAuth event logs on Google - All success
    Tried logging in to Google Applications like Gmail, Calendar, GDrive etc that I added to the Okta dashboard while connecting. After Successful authentication >> All I see is a message from Google on screen saying “Couldn’t sign you in. Contact your admin.”

I’m unsure what is causing the issue and completely unaware of how to resolve this.
I’ll be more than happy to provide more information if needed.

Any help is appreciated :slight_smile:

Thank you for reaching out here on the Okta Developer Forum. We noticed that your question is more closely related to SAML. To ensure you receive the most accurate and timely assistance, we recommend reposting your query on Okta’s Community at: Okta Help Center (Lightning)

Okta’s teams on the Community are better equipped to provide the comprehensive support and guidance you need as they have the specialised knowledge and expertise in SAML.

We appreciate your understanding and are committed to ensuring you receive the best possible support. If you have any other questions or issues related to Okta’s developer tools and API’s, feel free to post them here, and we’ll be happy to assist!