Unsupported_response_type Issue

Dear team,

I am trying to integrate okta in swagger ui ,
and facing given below issue:
Auth Error{“state”:“V2VkIEF1ZyAwMyAyMDIyIDA3OjU0OjUzIEdNVC0wNDAwIChFYXN0ZXJuIERheWxpZ2h0IFRpbWUp”,“error”:“unsupported_response_type”,“error_description”:“The+response+type+is+not+supported+by+the+authorization+server.+Configured+response+types:+[code].”}
I am struggling to get solution for above error, my details are as below:
Client ID :0oa61mwiewsu2C2dl5d7
GrantType :Authorization Code
Apptpye: OIDC/Web App
URL: dev-33312866.okta.com

, Hope to hear from you as our company looking to integrate okta as soon as possible to our 3 Api’s project.

prompt help will be highly appreciated.

Thanks
Sunil Kumar

What response_type do you see being sent in the /authorize request you’re making to Okta?

response_type=token

https://dev-33312866.okta.com/oauth2/default/v1/authorize?response_type=token&client_id=0oa618cw81ObxRf2y5d7&redirect_uri=
https%3A%2F%2Flocalhost%3A17472%2Fswagger%2Foauth2-redirect.html&scope=
openid&state=VHVlIEF1ZyAwMiAyMDIyIDA5OjM0OjQ0IEdNVC0wNDAwIChFYXN0ZXJuIERheWxpZ2h0IFRpbWUp

If you are requesting the token response_type, make sure you have the Implicit flow → Access token enabled for the application you made

After enabling Access implicit, give below error coming

Auth Error {“state”:“RnJpIEF1ZyAwNSAyMDIyIDAwOjM3OjUyIEdNVC0wNDAwIChFYXN0ZXJuIERheWxpZ2h0IFRpbWUp”,“error”:“invalid_request”,“error_description”:“The+‘nonce’+parameter+is+required+for+authorize+requests+with+either+the+‘id_token’+or+‘token’+response+types…”}

That is not working.

Kindly requested to share working Swagger implementation in .net core sample code.

Kindly give some solution for this, as we are first looking to integration okta oauth2 to in swagger ui

Now you need to make sure you include a nonce in your /authorize request, see our docs for more details about required parameters for the /authorize endpoint.

Hi Andrea, thank you for your suggestion,

Am passing nonce values as blank, that is working fine, but after authorization, not getting authorize button as locked for api’s end point in swagger, sharing screenshot

not sure I understand, whats not working now? Are you getting an error from the /authorize request?

Does, need to pass nonce as blank?