Workspace ONE Integration problem

Has anybody come across an issue where after setting up Workspace ONE with Okta, the app appears in the catalogue, the SAML appears to work but then Okta displays a 404 error? The error doesn’t help at all and the URL is:


Which appears to be looking for the correct app (RSA SAML Test) but just doesn’t work. The app works fine in Okta and was correctly pulled from Okta via an API call so I’m not sure what the issue is.

Hi @CC_Monty! Please open a support ticket through an email to with this issue. One of our Support Engineers will be happy to assist you in narrowing down the root cause of the error.

1 Like

Thanks. I’ve raised a case as suggested and if we get a solution I’ll try to remember to share here so that others can hopefully see what I ran into. :slight_smile:

1 Like

The Okta support team were able to help me resolve the issue. In the end it came down to the API integration that pulls the apps from Okta having an incorrect URL. Although the URL was correct enough to pull the app and assignment it was also building the link to follow from that URL and I had included the “-admin” part of the URL the section for the Okta tenant, so the app was getting it’s URL built incorrectly and thus the 404 resulted. Once this was changed to the correct URL everything worked well.

For reference the integration I am referring to is in Workspace ONE Access --> Identity and Access --> Setup --> Okta --> Okta Cloud URL

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.