Enable Default Scope


#1

Hi!

Just new with the library / this whole Authentication flow.

I am trying to setup to utilizing OpenConnect. However I encountered an error:

The authorization server resource does not have any configured default scopes, 'scope' must be provided.

From which I thought I can “enable” a default scope. So I went into the following page:

And I tried to enable at least the openid scope. But I cannot seem to do so:

It seems to be disabled. Or is because I am on a Developer account?

Had just tried each scope - and they are all disabled at the option of setting them as the Default scope.

Any thing that I might be doing wrong?


Michael


#2

You cannot set the standard OIDC scopes as “default”. Your app should be explicitly requesting scopes.

The default scope functionality is primarily intended for migration use cases where some legacy applications are unable to include a scope parameter in their OAuth request.


#3

Hi @john.gronberg,

Thanks for that clarification!


Michael