The response type is not supported login error

I am getting this error when trying to login. I have looked at other posts that say I need to have the Authorization Code box checked but but in my case it is checked.

I could use some guidance on getting this to work. This is my first attempt at using OKTA so I could be doing something else wrong but I have followed the tutorials.

Thank you This the error I am getting

http://localhost:3000/implicit/callback?state=f9HXGzZeGz6t1ShGVK1thZ9taBQbJBQMbtJM2ROi0MK1q8IAtz8dRLBTo3XW2Swh&error=unsupported_response_type&error_description=The+response+type+is+not+supported+by+the+authorization+server.+Configured+response+types%3A+[id_token%2C+token].

what is the request you are sending from the perspective of requested response_type?

this is code for loginbutton.js.

import React, { Component } from ‘react’;
import {
Button,
IconButton,
Menu,
MenuItem,
ListItemText,
} from ‘@material-ui/core’;
import { AccountCircle } from ‘@material-ui/icons’;
import { withOktaAuth } from ‘@okta/okta-react’;

export default withOktaAuth(class Home extends Component {
constructor(props) {
super(props);
this.login = this.login.bind(this);
}

async login() {
this.props.authService.login(’/profile’);
}

render() {
if( this.props.authState.isPending ) {
return (

Loading authentication…

);
} else if( !this.props.authState.isAuthenticated ) {
return (

Login

);
}
}
});

Can you capture a request on a network tab, which was sent to okta’s /authorize endpoint?

Sorry this still a little new to me. This is what I get in the network tab after hitting the login link. Manifest.json status 200 the url however gives an error code that looks like this

http://localhost:3000/implicit/callback?state=p89YenlghkYfWQe3nzL1RQSV98BsOKR2xgxaYIoZ2D8SBxTUOijD54vTBzHI7QVz&error=unsupported_response_type&error_description=The+response+type+is+not+supported+by+the+authorization+server.+Configured+response+types%3A+[id_token%2C+token].

Hi @kstomp

Based on the error message inside the query parameter error_description, can you please check that you have added a SPA application and have authorization code enabled?

There is a SPA application and the authorization code box is checked