Developer preview , has SAML support discontinued


#1

Hi Developers,

I am new to okta and have created an account to setup preview instance. But when I go to

okta -> Add applications ->Web -> Create new application

Now under the application settings it shows the settings options which are related to OpenId.

Nowhere can I find an option to create application type as supporting SAML.

So my query is, how can I setup preview instance supporting SAML? or has it been obsolete.

Thanks
pchh


#2

Hi @pchh,

You can access the SAML Creation Wizard by switching to the Classic UI.

Taken from Setting Up A SAML Application In Okta:

  1. If you are using the developer dashboard you will first need to switch to the Classic UI. If you see a < > Developer prompt in the top left, click it and select Classic UI to switch to the Classic UI.

  2. Log in to your Okta organization as a user with administrative privileges.

  3. Click on the blue “Admin” button Admin

  4. Click on the “Add Applications” shortcut Add Applications

  5. Click on the green “Create New App” button Create New App

  6. In the dialog that opens, select the “SAML 2.0” option, then click the green “Create” button


#3

Thanks @jmelberg. That will help me a lot.


#4

Hi @jmelberg
I was able to sucessfully create a new application(for back end) on Web platform(referred Spring boot tutorial) with sign on method as SAML.

Now our front end is built in Angular, when I go to Okta UI to create a new application in Okta and select the Platform as Single Page App (SPA) it shows the sign on method as OpenID Connect only (SAML is not shown in option list). So is there a way to use SAML also in case of Angular/SPA or the OpenID connect is the only option. with Angular/SPA