Getting "400 Bad Request Error after updating trusted origins

I have a Nodejs app running on port 8080 (using nginx w/ reverse proxy, if that matters). Authorization works fine on my local machine, but from the production site (flashkubes.com), I get the error " The ‘redirect_uri’ parameter must be an absolute URI that is whitelisted in the client app setting."

I’ve added the website url to the client whitelist as shown here:

My web app starts with this configuration:
02%20AM

So, I can’t figure out what can be going wrong here. Any advice??

(I’ve also tried changing the port number in the config file to 80, but without success)

Thanks!

Got it working: seems the ‘redirectUri’ has to start with https instead of http.