Okta self service is set allowed in profile enrollment but still cant see signup link/button or form in React SPA

this is my conifg
clientId: '0xxx,
issuer: 'myissuer,
redirectUri: “http://localhost:3000/login/callback”,
scopes: [‘openid’, ‘profile’, ‘email’],
pkce: true,
disableHttpsCheck: true,

in profile enrollment self register is set true , progressive false but still no luck

Can you check if your OpenID Connect app within Okta is configured to be assigned to users that complete self service registration?

You might be running into the issue described in this article: “Sign Up” Link Missing from Okta Login Page During SP-initiated Login | Okta Help Center

federation is enabled , sign on OpenID Connect is selected , progressive profiling is set to false , Self service is Allowed , groups is assigned to “somegroup”

can you please please help me with this

And are users that enroll via Profile Enrollment set to be added to the same group that is also assigned to your target app?

yes app and the profile enrollment all uses same group “mygroup”

What widget version are you currently using? Is it Widget v7.x?

@okta/okta-signin-widget”: “^6.3.3”,

Can you try setting useInteractionCodeFlow to true in your widget config and retry?

i tried that earlier it breaks and the sing in fields are gone too when i set it to true

oh really? You will definitely need useInteractionCodeFlow turned on for the widget to use IDX and show the Sign Up button for profile enrollment. This is set as the default in Widget 7.x, but does need to be turned on in widget 5.x and 6.x, otherwise it will attempt to use the old Okta Classic /authn login flow which doesn’t support profile enrollment.

I wonder if there’s something missing in your widget config that means it won’t load because its missing something required for the IdX flow. What does the rest of your widget config look like?

And I assume above that cut-off you have issuer and clientId getting set? If so, that config looks good to me.

Do you see any errors in the browser console?

no error shows , just missing link when using userInteractionCodeFlow = true the widget wont load

Can you try using our sample app? I just checked it in my own org, and I do see the Sign Up button shown.

If you are still having trouble even with the sample app, make sure you confirm the following:

  • Under Settings → Account, ensure that Interaction Code is enabled
    Screenshot 2024-03-20 at 1.21.08 PM
  • In your OIDC apps General settings tab, ensure that Interaction Code is enabled as an allowed grant type (this option will not appear until you enable the option under Settings → Account)

thank you so so so so so so much andreaaaa ! , i was so lost but now its finally working , thank you for your help

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.