Self service registration not working

I am using vue widget for custom login and singup, I have enabled the self service registration and the login seems to work fine but the signup keep throwing error: Registration cannot be completed at this time. here’s attached screenshot.
self signup

Tried the Post Link on postman and got this error:

    // 20200909123959
// https://dev-374370.okta.com/api/v1/registration/regw61016dBeHBjyf4x6/register

{
  "errorCode": "E0000022",
  "errorSummary": "The endpoint does not support the provided HTTP method",
  "errorLink": "E0000022",
  "errorId": "oaeIfF-C7HFQRGtsHGrFjwVog",
  "errorCauses": [
    
  ]
}

Do you have any REQUIRED custom Okta User Profile attributes? If yes some of them might not be populated and you would get this error.

The error message you have shown in your question implies that in Post man you have not set the request to be POST request. Also you might be missing the json payload and/or some headers…

Also, can you show what is the actual error message returned by Okta after clicking the Register button? You can see this in the network tab in Developer tools in your browser…

yes there is a single custom profile attribute. this is the response from my postman

This the error at my console

okta-sign-in.entry.js?4d6a:44 POST https://dev-374370.okta.com/api/v1/registration/regw61016dBeHBjyf4x6/register 400
send @ okta-sign-in.entry.js?4d6a:44
ajax @ okta-sign-in.entry.js?4d6a:44
t.ajax @ okta-sign-in.entry.js?4d6a:52
t.sync @ okta-sign-in.entry.js?4d6a:52
sync @ okta-sign-in.entry.js?4d6a:52
save @ okta-sign-in.entry.js?4d6a:52
registerUser @ okta-sign-in.entry.js?4d6a:90
eval @ okta-sign-in.entry.js?4d6a:90
preSubmit @ okta-sign-in.entry.js?4d6a:45
save @ okta-sign-in.entry.js?4d6a:90
eval @ okta-sign-in.entry.js?4d6a:21
g @ okta-sign-in.entry.js?4d6a:52
m @ okta-sign-in.entry.js?4d6a:52
c @ okta-sign-in.entry.js?4d6a:52
l.trigger @ okta-sign-in.entry.js?4d6a:52
__save @ okta-sign-in.entry.js?4d6a:21
eval @ underscore.js?17fb:804
submit @ okta-sign-in.entry.js?4d6a:21
dispatch @ okta-sign-in.entry.js?4d6a:44
g.handle @ okta-sign-in.entry.js?4d6a:44
13:22:13.133

Error at my network tab:

1. general:
    Request URL: https://dev-374370.okta.com/api/v1/registration/regw61016dBeHBjyf4x6/register
Request Method: POST
Status Code: 400 
Remote Address: 3.15.36.194:443
Referrer Policy: no-referrer-when-downgrade
  1. response header:
    access-control-allow-credentials: true
    access-control-allow-headers: Content-Type
    access-control-allow-origin: http://localhost:8080
    cache-control: no-cache, no-store
    content-security-policy-report-only: default-src ‘self’ *.oktacdn.com dev-374370.okta.com; connect-src ‘self’ *.oktacdn.com *.mixpanel.com *.mapbox.com app.pendo.io data.pendo.io pendo-static-5634101834153984.storage.googleapis.com dev-374370.okta.com dev-374370-admin.okta.com https://oinmanager.okta.com data:; script-src ‘unsafe-inline’ ‘unsafe-eval’ ‘self’ *.oktacdn.com; style-src ‘unsafe-inline’ ‘self’ *.oktacdn.com app.pendo.io cdn.pendo.io pendo-static-5634101834153984.storage.googleapis.com; frame-src ‘self’ login.okta.com dev-374370.okta.com dev-374370-admin.okta.com; img-src ‘self’ *.oktacdn.com dev-374370.okta.com *.tiles.mapbox.com *.mapbox.com app.pendo.io data.pendo.io cdn.pendo.io pendo-static-5634101834153984.storage.googleapis.com data: blob:; font-src data: ‘self’ *.oktacdn.com fonts.gstatic.com; report-uri https://okta.report-uri.com/r/d/csp/reportOnly; report-to csp-report
    content-type: application/json;charset=UTF-8
    date: Wed, 09 Sep 2020 12:29:58 GMT
    expires: 0
    p3p: CP=“HONK”
    pragma: no-cache
    public-key-pins-report-only: pin-sha256=“r5EfzZxQVvQpKo3AgYRaT7X2bDO/kj3ACwmxfdT2zt8=”; pin-sha256=“MaqlcUgk2mvY/RFSGeSwBRkI+rZ6/dxe/DuQfBT/vnQ=”; pin-sha256=“72G5IEvDEWn+EThf3qjR7/bQSWaS2ZSLqolhnO6iyJI=”; pin-sha256=“rrV6CLCCvqnk89gWibYT0JO6fNQ8cCit7GGoiVTjCOg=”; max-age=60; report-uri=“https://okta.report-uri.com/r/default/hpkp/reportOnly
    report-to: {“group”:“csp-report”,“max_age”:31536000,“endpoints”:[{“url”:“https://okta.report-uri.com/r/d/csp/reportOnly"}],"include_subdomains”:true}
    server: nginx
    set-cookie: sid=""; Expires=Thu, 01-Jan-1970 00:00:10 GMT; Path=/
    set-cookie: JSESSIONID=82B00E49F50E22AD764A042C48A7C868; Path=/; Secure; HttpOnly
    status: 400
    strict-transport-security: max-age=315360000; includeSubDomains
    vary: Origin
    x-content-type-options: nosniff
    x-okta-request-id: X1jKxsEInBvlR-@hs2@WhwAABoY
    x-rate-limit-limit: 1000
    x-rate-limit-remaining: 999
    x-rate-limit-reset: 1599654658
    x-xss-protection: 1; mode=block; report=https://okta.report-uri.com/r/d/xss/enforce

  2. request header:
    :authority: dev-374370.okta.com
    :method: POST
    :path: /api/v1/registration/regw61016dBeHBjyf4x6/register
    :scheme: https
    accept: application/json, text/javascript, /; q=0.01
    accept-encoding: gzip, deflate, br
    accept-language: en-US,en;q=0.9,ja;q=0.8
    content-length: 122
    content-type: application/json
    origin: http://localhost:8080
    referer: http://localhost:8080/signin/register
    sec-fetch-dest: empty
    sec-fetch-mode: cors
    sec-fetch-site: cross-site
    user-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.83 Safari/537.36
    x-okta-xsrftoken

  1. Can you show the actual response body from the register request in the network tab?
  2. Can you remove the custom attribute in the Okta profile, or at least make it not required?

let me remove it the required attribute and try again:

Update 1:
I removed the required custom attribute and it works.

Please, is there a way i can force users to fill in the custom attribute?
Update 2:
I’ve found a way of doing it by adding required at the self service registration.

Thanks a lot

1 Like